Cisco router VPN сервер для PPTP L2TP соединений

Резервное копирование конфиг файлов cisco.
Резервное копирование конфиг файлов cisco.
17.03.2017
Миграция ролей AD и DNS с ОС Windows Server 2003 на windows server 2008 r2
Миграция ролей AD и DNS с ОС Windows Server 2003 на windows server 2008 r2
17.03.2017

Cisco router VPN сервер для PPTP L2TP соединений

Cisco router VPN сервер для PPTP L2TP соединений

Cisco router VPN сервер для PPTP L2TP соединений

Статья написана для всех нуждающихся, а так же как «пендель» всем «умникам» рассказывающим что сие сделать без RADIUS-a не возможно.
Итак данный конфиг описывает как поднять на Cisco router VPN сервер для PPTP L2TP соединений. На примере юзера test

Особенности:
1. при введении определенного логина присваивается определенный IP адрес.
2. Для работы по L2TP требуется прописать дополнительно слово пароль “cisco”.

aaa new-model ! Включаем работу с Authorization Authentication Accounting!
aaa authorization network default local ! Авторизация сетевых сервисов локальная (именно тут происходит связка Login <=> IP)
!
aaa attribute list test
attribute type addr 10.0.0.100 service vpdn
!
vpdn enable!
vpdn-group VPDN-L2TP ! Создаем профиль для L2TP соединений
!

Default L2TP VPDN group
accept-dialin
protocol l2tp
virtual-template 2
lcp renegotiation on-mismatch
l2tp security crypto-profile L2TP
no l2tp tunnel authentication
ip pmtu
ip mtu adjust!
vpdn-group VPDN-PPTP ! Создаем профиль для PPTP соединений
!

Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
pptp tunnel echo 10
ip pmtu
ip mtu adjust!
async-bootp dns-server 8.8.8.8 ! Выдавать данный ДНС в настройках VPN соединения
!
username test password 0 testusername test aaa attribute list test
!
crypto isakmp policy 100 ! Данные настройки относятся к методу шифрования ключа в L2TP VPN
encr 3des
hash md5
authentication pre-share
group 2
lifetime 3600crypto isakmp key cisco address 0.0.0.0 0.0.0.0 no-xauth ! Общее слово пароль Windows Сетевое соединение -> Безпасность -> Параметры IPSEC
!
crypto ipsec transform-set L2TP esp-des esp-md5-hmac ! Данные настройки относятся к методу шифрования данных в L2TP VPN
mode transport
!
crypto map L2TP 100 ipsec-isakmp profile L2TP ! Сборка настроек в единую криптомапу
set transform-set L2TP
!
interface Loopback0 ! Используем данный интерфейс для навешивания IP в Virtual-Template интерфейсах
ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0 !Внешний интерфейс
ip address 172.17.12.122 255.255.252.0
speed auto
crypto map L2TP ! Прикручиваем криптомапу. Требуеться для создания Windows L2TP тунелей
!
interface Virtual-Template1 ! Настройки интерфесов которые создают PPTP тунель
ip unnumbered Loopback0
ip nat inside
no ip virtual-reassembly
autodetect encapsulation ppp
peer default ip address pool VPN-pool
ppp encrypt mppe auto
ppp authentication chap ms-chap ms-chap-v2
!
interface Virtual-Template2 ! Настройки интерфесов которые создают L2TP тунель
ip unnumbered Loopback0
ip nat inside
no ip virtual-reassembly
autodetect encapsulation ppp
peer default ip address pool VPN-pool
ppp authentication chap ms-chap ms-chap-v2
!
ip local pool VPN-pool 10.0.0.2 10.0.0.254 ! Наш пул адресов для VPN соединений

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *